Le plaisir de voler avec son simulateur de vol (Flight Simulator X et Prepar3D). Le forum FSX-France est un lieu d'échange, sujet principal: la simulation aérienne.
 
AccueilPortailCalendrierRechercherMembresS'enregistrerConnexion
FSX-France fête ses 5 ans le 31 juillet 2017


Partagez  | 
 

 Problème avec un GIF

Voir le sujet précédent Voir le sujet suivant Aller en bas 
AuteurMessage
Super Mario

avatar
Membre



Masculin Age : 43
Date d'inscription : 05/09/2012
Messages : 219
Version à définir

MessageSujet: Problème avec un GIF   Sam 5 Jan 2013 - 18:49

Bonjour à tous,

Pardon de vous embêter sur ce forum avec un problème venant de mon propre forum, mais je suis perdu... scratch

J'ai remplacé les icones de 'nouveau message' et 'pas de nouveau message' par des images GIF. Quand il y a de nouveaux messages, le GIF clignote.
Tout fonctionne bien avec Chrome et Firefox, mais ça ne clignote pas avec Internet Explorer 10... et je ne comprends pas pourquoi ! Snif

Alors si vous avec des idées, je suis preneur !

Bon week-end à tous
Revenir en haut Aller en bas
Shag

avatar
Administrateur

En ligne

Masculin Age : 40
Date d'inscription : 03/06/2012
Messages : 3309
Numéro du département : 14
Version à définir Possède P3D

MessageSujet: Re: Problème avec un GIF   Dim 6 Jan 2013 - 10:50

Salut l'ami,

Tu parles d'image, celui du dernier posteur ?

Si c'est le cas, voici le code java:


$(function(){

if(!window.localStorage) return;

// Avatar par défaut
var default_avatar= 'https://illiweb.com/fa/invision/pp-blank-thumb.png';

// Temps de cache, ici 24 h * 60 m * 60 s * 1000 ms donc un jour
var caching_time= 24*60*60*1000;

// Temps de cache d'une erreur, ici 60 s * 1000 ms donc une minute
var caching_error= 60*1000;

var set_avatar= function(id) {
$('.mini_ava.member'+id).html('');
};

var get_avatar= function(id) {
if(localStorage.getItem('t_ava'+id) < +new Date - caching_time || (localStorage.getItem('d_ava'+id)==default_avatar && localStorage.getItem('t_ava'+id) < +new Date - caching_error))
{
localStorage.setItem('d_ava'+id, default_avatar);
$.get('/u'+id, function (d){
localStorage.setItem('t_ava'+id,+new Date);
localStorage.setItem('d_ava'+id, $('#profile-advanced-right .module:first div img:first,.forumline td.row1.gensmall:first > img, .frm-set.profile-view.left dd img,dl.left-box.details:first dd img, .row1 b .gen:first img, .real_avatar img',d).first().attr('src')||default_avatar);
set_avatar(id);
});
}
return localStorage.getItem('d_ava'+id);
};

var to_replace= {};

$('dd.lastpost strong a.gensmall, .ipbtable tr td:last-child span strong a.gensmall, .table td.tcr strong a.gensmall, .forumline .row3.over strong a.gensmall').each(function(){
to_replace[$(this).attr('href').substr(2)]= 1;
$(this).closest('td,dd').prepend('
');
});

for(i in to_replace)
{
set_avatar(i);
};

});




J'espère t'avoir aidé, sinon, fait un petit screen de ton souci.

Mes amitiés.

Shag


Revenir en haut Aller en bas
En ligne
Super Mario

avatar
Membre



Masculin Age : 43
Date d'inscription : 05/09/2012
Messages : 219
Version à définir

MessageSujet: Re: Problème avec un GIF   Dim 6 Jan 2013 - 11:15

Non Shag, ce n'est pas ça...

Voici un screen



L'image 'nouveaux messages' est la même que 'pas de message' mais en clignotant. C'est une image en .gif clignotant à la base...
Ca fonctionne avec tous les navigateurs testés excepté IE 10. Sans doute un réglage, mais lequel ?

En tout cas, merci de ta réponse !
Revenir en haut Aller en bas
Shag

avatar
Administrateur

En ligne

Masculin Age : 40
Date d'inscription : 03/06/2012
Messages : 3309
Numéro du département : 14
Version à définir Possède P3D

MessageSujet: Re: Problème avec un GIF   Dim 6 Jan 2013 - 11:21

Bétise Tu vois pourquoi je ne prend pas mon avion le dimanche matin...

Sinon, je n'ai malheureusement pas la réponse.

Mes amitiés.

Shag



Revenir en haut Aller en bas
En ligne
Kagg

avatar
Membre



Masculin Age : 41
Date d'inscription : 01/10/2012
Messages : 179
Version à définir

MessageSujet: Re: Problème avec un GIF   Mer 9 Jan 2013 - 9:44

Plop Mario,

Tu dois paramétrer Internet explorer pour qu'il lise les animations des pages Web

Donc, tu vas dans "Menu outils" ---> options internet --> avancé et tu coches " lire les animations dans les pages Web"

C'est la politique de Crosoft ça. C'est comme dans les nouvelle versions d'Outlook (en tant que programme client), avant, les gif animé qu'on "collait" dans un mail étaient animés, maintenant, ce n'est plus le cas. Crosoft qui pousse Silverlight en fait ^^

Tiens-nous au courant.

A plus tard

Kagg
Revenir en haut Aller en bas
Super Mario

avatar
Membre



Masculin Age : 43
Date d'inscription : 05/09/2012
Messages : 219
Version à définir

MessageSujet: Re: Problème avec un GIF   Jeu 10 Jan 2013 - 8:15

Merci Kagg, mais cette option est bien cochée...


Je pense effectivement que c'est un paramétrage d'IE puisque c'est le seul avec lequel ça ne fonctionne pas... Mais lequel, mystère...
Revenir en haut Aller en bas
 
Problème avec un GIF
Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 1 sur 1

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
FSX-France :: L'espace détente :: Le bar des pilotes-